Closed

Bug 148624


Opened 22 years ago
Closed 1 month ago

Tracking Status
firefox119 fixed

Assignee: Matti → jaggernaut

Status: UNCONFIRMED → NEW

Component: Browser-General → XP Toolkit/Widgets

Ever confirmed: true

QA Contact: imajes-qa → jrgm

OS: MacOS X → All

Hardware: Macintosh → All

The severity field for this bug is relatively low, S3. However, the bug has 8 duplicates and 15 votes.


:enndeakin, could you consider increasing the bug severity?

For more information, please visit auto_nag documentation.

Flags: needinfo?(enndeakin)

The last needinfo from me was triggered in error by recent activity on the bug. I’m clearing the needinfo since this is a very old bug and I don’t know if it’s still relevant.

Flags: needinfo?(enndeakin)

Still reproducible (and still extremely annoying) with Thunderbird 102.4.1 (64-bit) and Firefox 106.0.1 (64-bit) on GNU/Linux. When I’m multitasking, I need to manually minimize Thunderbird in order to prevent its tooltips from interfering from my work in other windows.

Not reproducible with SeaMonkey 2.53.14, so maybe this isn’t a Core product issue after all, or maybe SeaMonkey has done something to override the bad behaviour. Maybe the Firefox and Thunderbird developers can see what SeaMonkey has done to fix the issue and implement the same fix.

This 21 year old bug is still open. It is quite annoying, to be frank — happens to me at least once per day.

That said, given its longevity, I’m kinda partial to let it be forever. It feels like a relic from the past.

Hi, still happening to me too (OS: KDE Neon 22.04).


Firefox v113.0.2

Still happening on Firefox 115.0.2 + GNOME 44.

I just browser-hopped back to firefox this week and this was one of the larger annoyances, as I trigger it constantly.

For people who find this page via search engine, like me, the solution I’m using is to disable tooltips entirely, with the setting browser.chrome.toolbar_tips. It’s a weird thing to have to resort to, but I don’t think there’s really any situation where I’ll miss them.

I am also experiencing this bug.

Version: firefox 117.0, clean profile; also thunderbird 115.2.0. Using xfce with xfwm.

Steps to reproduce:

Hover mouse over element that will generate tooltip.
Just as the tooltip is a about to appear, but before the tooltip appears, use hotkey to switch to another workspace.

Symptoms:


The tooltip will appear in the other workspace, and will not disappear until I switch back to firefox and move my mouse.

Assignee: nobody → fanzhuyifan+github

Status: NEW → ASSIGNED

(In reply to fanzhuyifan+github from comment #45)

I am also experiencing this bug.

Version: firefox 117.0, clean profile; also thunderbird 115.2.0. Using xfce with xfwm.

Steps to reproduce:

Hover mouse over element that will generate tooltip.
Just as the tooltip is a about to appear, but before the tooltip appears, use hotkey to switch to another workspace.

Symptoms:


The tooltip will appear in the other workspace, and will not disappear until I switch back to firefox and move my mouse.

Reproducing the bug on firefox-nightly, on linux, xorg, xfce with xfwm.

Updated Steps to reproduce:

  • Hover mouse over browser element that will generate tooltip (e.g., task bar. not webpage elements with tooltips)
  • alt-tab to another window or use quick key to switch to another workspace

I think a better fix would be for widget to send a window-level mouse exit event when the workspace switch happens. But I’m not sure where that code would go or how we would detect this situation.

The nodes are already getting focusout events when workspace switches. This means some part of the code must already be detecting this situation, right?

Attachment #9351511
Attachment description: Bug 148624 – cancel tooltip timer on focusout. r=mstange,cmartin → Bug 148624 – only show tooltip when document has focus. r=mstange,cmartin

Status: ASSIGNED → RESOLVED

Closed: 1 month ago

Resolution: — → FIXED

Target Milestone: — → 119 Branch

For me the bug only shows up when MOZ_ENV_XINPUT2 is set to 1. The bug disappears as soon as MOZ_ENV_XINPUT2 is set to 0.

Summary: Tooltips persist in foreground when Mozilla is in background → Tooltips persist in foreground when Firefox is in background

(In reply to fanzhuyifan+github from comment #53)

For me the bug only shows up when MOZ_ENV_XINPUT2 is set to 1. The bug disappears as soon as MOZ_ENV_XINPUT2 is set to 0.

That’s bug 1809029. I can’t repro but fixes are welcome.

Read More